25th June 2020

RDS Access RDS - Chrome and IE - Webpage not loading

UPDATE - 11/08/20 14:35 Access issue is now resolved following an E-Safe upgrade to the latest version being performed addressing the issue and confirmed by Helpdesk who report no further access issues being raised.

UPDATE - Some users might experience issues accessing the Staffnet homepage through Google Chrome or Internet Explorer whilst using the RDS system.

We are working with a 3rd party to investigate and resolve the issue and will update you soon.

If you experience any issues please call the Helpdesk on 0115 912 5555 or email icthelpdesk@nottinghamcollege.ac.uk